Membuat Password Acak di Mikrotik

Membuat Password Acak atau Random Password di Mikrotik sering terdapat pada penggunakan untuk Hotspot di sisi User Managernya.

Penggunaan User Manager akan melakukan system konfigurasi dengan menggunakan tampilan WebGUI sesuai dengan kebutuhan anda, mulai dari pengaturan paket waktu hingga management bandwitdhnya.

Namun kita coba bermain dengan script mikrotik untuk melakukan random atau pengacakan dalam hal pembuatan password untuk keperluan hotspot misalnya.

Perhatikan secara seksama Script dibawah ini yang kami berikan, selanjutnya anda bisa melakukan modifikasi sesuai dengan keinginan anda.

Script dibawah ini akan menghasilkan 3 karakter password secara Random / acak.

#add firewall rules
/ip firewall filter
add action=passthrough chain=forward random=5 comment=r1
add action=passthrough chain=forward random=2 comment=r2
add action=passthrough chain=forward random=3 comment=r3

Lalu masukkan SCRIPT RANDOM PASSWORD dibawah ini :

# define char table
:global chArray a,b,c,d,e,f,g,h,i,j,k,l,m,n,o,p,q,r,s,t,u,v,w,x,y,z
:local strPass "";

#get counters
:local ch1num [/ip firewall filter get [find comment=r1] packets ];
:local ch2num [/ip firewall filter get [find comment=r2] packets ];
:local ch3num [/ip firewall filter get [find comment=r3] packets ];

# make sure counter is not larger than 25
if ( ch1num > 25 ) do={ /ip firewall filter reset-counters [find comment=r1]; :set ch1num 0; };
if ( ch2num > 25 ) do={ /ip firewall filter reset-counters [find comment=r2]; :set ch2num 0; };
if ( ch3num > 25 ) do={ /ip firewall filter reset-counters [find comment=r3]; :set ch3num 0; };

# generate password
:set strPass ( [:tostr [ :pick $chArray $ch1num ]] . [:tostr [:pick $chArray ch2num ]] . [:tostr [:pick $chArray $ch1num ]] );

:put $strPass ;

#the end

Semoga bermanfaat,
Jika kurang jelas..anda bisa lihat DISINI ...



Pages